Cadillac CTS-V Forum banner

2461 - 2466 of 2466 Posts

·
Premium Member
Joined
·
12,761 Posts
removed low temp thermostat that I assume stuck yesterday and replaced with OEM one
I pulled up to my shop just as the needle approached 260
 

·
Premium Member
Joined
·
242 Posts
146274


4th alignment in two years. Hopefully the last for a while.

  • New upper/lower control arms with CS red bushings
  • WPX sway bar (need to install rear still)
  • 275/35/19 General Gmax RS x 4
Should be fun...
 
  • Like
Reactions: V_Wagon

·
Registered
Joined
·
1,256 Posts
After a stupid moment, I had to pull my WB O2 sensor to free air calibrate it again. Last week I managed to get into the Calibration screen when trying to set my AFR display from the default max reading of 16 to 20 (or 1.1λ to 1.37λ) trying to save the changes that the Owners Manual doesn't tell you how to do. Otherwise you have to change it each time you power up the unit. I realized I had gone into the Calibration screen and immediately hit the mode button again which failed the Calibration test. I contacted NGK and the Tech told me how to save the mode 20 (1.37λ) setting by holding the mode button for 3 seconds after changing from the default mode 16 (1.1λ) to mode 20 (1.37λ) and recommended I recalibrate the sensor.

Sure would be nice if that would have been in the manual.

Wasn't as bad I thought it would be because I put the sensor in the pipe before I put the pipe in the car. Was able to get my cressent wrench on it and do it. Only took about 30 minutes of stupid correction time.
 
2461 - 2466 of 2466 Posts
Top