Cadillac CTS-V Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter · #1 ·
I recently added a Cam, everything runs great and at 640 WHP, when driving normal and I let up on the gas I get quite a bit of exhaust pop, pop, pop, is that from the tune or cam selection? Or is it just normal for a modified, cam cars?

I also notice that when it is cold I get hesitation when pulling out on the street, I just falls flat on it’s face when giving it moderate acceleration, runs fine when weather and car is warm.

Cam is


Dino



Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
478 Posts
Tune is reason for pops, car is burning off the leftover fuel aka running rich.
Also by chance did you add a stall in your transmission with the upgrade?
Or are you 6M?
Some cams are spec’d to need a stall, some aren’t. It does sound like it needs a retune for street use.
 

·
Premium Member
Joined
·
4,354 Posts
The tuner can turn off the DFCO, which results in many bangs and pops and makes your car sound like a 16yo is driving it. Lol
 

·
Registered
Joined
·
434 Posts
its all tune related, hesitation is prob too low timing or it goes a little lean at that point causing a stumble, watching the 02's if u dont have WB will let u know if its fueling or not
 

·
Registered
Joined
·
78 Posts
The fact that you are getting hesitation and popping especially at start indicates it is most likely running way too rich. Too much fuel can also cause a misfire or hesitation. When the car starts it is programmed to run rich (starts at like .78 lambda) So if your tune is off it could be running in the .6's or lower which will cause you misfires and backfires.

Also if you have cats, they will be destroyed in time from this.
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #6 ·
Thanks, for the feedback very helpful. I am bringing it back to him this week. He is a pretty good shop for my area, Raleigh NC, but worried if he didn’t get it right the first time that maybe I need a second opinion?


Sent from my iPad using Tapatalk
 
  • Like
Reactions: Omgctsv

·
Registered
Joined
·
229 Posts
Discussion Starter · #7 ·
The fact that you are getting hesitation and popping especially at start indicates it is most likely running way too rich. Too much fuel can also cause a misfire or hesitation. When the car starts it is programmed to run rich (starts at like .78 lambda) So if your tune is off it could be running in the .6's or lower which will cause you misfires and backfires.

Also if you have cats, they will be destroyed in time from this.
Yes you are correct, I did have Cats, but I recently added a ported TB and when they did the work they noted the Cats were going bad, so I had them gutted. Seems the tune has been an issue for a while,

Another strange issue I wasn’t sure was related or not. I also added a WB and the O2 seems to bounce between 14.x and 19, I thought this was a wiring issue, but maybe related to tune as well?


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
1,787 Posts
Another strange issue I wasn’t sure was related or not. I also added a WB and the O2 seems to bounce between 14.x and 19, I thought this was a wiring issue, but maybe related to tune as well?
Shouldn't bounce that much.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top