Cadillac CTS-V Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
791 Posts
Discussion Starter #1
I have a gold blade ported 90mm ls3 from Mamo, after trying two I keep going into limp mode. I think the TB is fine, just does not like my setup and car. So I purchased a silver blade Ls2 90mm not ported. Works fine with no limp mode. My blower is ported and snout is ported out to match a ported 90. Now it feels a little less responsive and I wonder if I have left any power on the table. The idle is MUCH better now for sure and I can see how the porting may have been part of that equation.

So my question is, can I swap the internals including the blade and make use of the ported housing? They look identical to the naked eye, but not sure if I am wasting time being stupid or it this will never happen for reasons I am overlooking.
 

·
Registered
Joined
·
791 Posts
Discussion Starter #3
Tony did not port work, I can only assume that he did with as many as he has done. That a we tried two separate ones left me thinking it is something else as I have read some of our cars just don’t like the gold blades. It actually ran fine on the second one for about 2 weeks. Thus I gave up after it jacked up a private track day with the V club
 

·
Registered
Joined
·
2,532 Posts
im having the same problem with my ported gold blade right now. Keeps bogging on shift or going into limp mode
 

·
Registered
Joined
·
312 Posts
I had to recenter my TB blade as it was not done before my install. It would start, idle fine, soon as I accelerated the blade would catch, get stuck and go into limp mode. Mamo Ported LS7 TB. I didn't even notice it was off center when the blade was closed.

If this is the case you will see some wear spots from where the blade was hitting the body.
 

·
Registered
Joined
·
2,532 Posts
I had to recenter my TB blade as it was not done before my install. It would start, idle fine, soon as I accelerated the blade would catch, get stuck and go into limp mode. Mamo Ported LS7 TB. I didn't even notice it was off center when the blade was closed.

If this is the case you will see some wear spots from where the blade was hitting the body.
Ill have to check this out, thanks
 
  • Like
Reactions: NTX-V

·
Registered
Joined
·
791 Posts
Discussion Starter #7
Yep same deal, down shit and bad shudder until you get out of it. Any shift at WOT above 1st to 2nd and limp mode. I bought an AC Delco LS2 from Jegs for about $380, works flawless. Just hate to waste the ported one that was even more than that. Should have went with a Nick 102 boosted from the beginning, but then I am getting into porting the snout even more and even more cost. UGH it never ends. We got a 1/2 mile event in a 9 days so I hate to go jack with it unless this is something other than a snipe hunt. I may just sell it and be done at this point and be upfront with what I have experienced, I truly believe it’s fine, and just my set up. .

But im going to check out the blade on the Mamo right now... I may be asking how to “recenter” soon!
 

·
Registered
Joined
·
791 Posts
Discussion Starter #8
So I got it out and I am not sure how I would even adjust it honestly. I don’t really see an obvious dragging marks either. I am assuming it is a left right side to side adjustment rather than an up down on either side?







 

·
Registered
Joined
·
791 Posts
Discussion Starter #9
Not sure if these next shots skew it or help.



 

·
Registered
Joined
·
1,341 Posts
Yep same deal, down shit and bad shudder until you get out of it. Any shift at WOT above 1st to 2nd and limp mode. I bought an AC Delco LS2 from Jegs for about $380, works flawless. Just hate to waste the ported one that was even more than that. Should have went with a Nick 102 boosted from the beginning, but then I am getting into porting the snout even more and even more cost. UGH it never ends. We got a 1/2 mile event in a 9 days so I hate to go jack with it unless this is something other than a snipe hunt. I may just sell it and be done at this point and be upfront with what I have experienced, I truly believe it’s fine, and just my set up. .

But im going to check out the blade on the Mamo right now... I may be asking how to “recenter” soon!
I'm in for the results. Have the same Mamo 90 that I just installed along with cam and a bunch of other things, but yes this happened to me as well. If the recentering is what fixes it, I'll be glad to if some could take me to a post or video showing how would be awesome.. Finger crossed for you that this gets resolved and you can do your 1/2 mile with all the goodies..
 

·
Registered
Joined
·
312 Posts
I had to push my blade closed, it looks like yours is at a part open position. You should be able to gently move the blade full closed to full open. Below are the pictures of my TB where it was getting stuck.

I self remedied my issue, I am not a throttle body expert... But barely loosen the two star head screws that hold the blade. It took me 3 or 4 times of small shifts of the blade to make it move freely in the body. I used a dark room and a flashlight to make sure when the TB was closed minimal light showed through.

Mine has never had an issue since and pulls hard.











Yep same deal, down shit and bad shudder until you get out of it. Any shift at WOT above 1st to 2nd and limp mode. I bought an AC Delco LS2 from Jegs for about $380, works flawless. Just hate to waste the ported one that was even more than that. Should have went with a Nick 102 boosted from the beginning, but then I am getting into porting the snout even more and even more cost. UGH it never ends. We got a 1/2 mile event in a 9 days so I hate to go jack with it unless this is something other than a snipe hunt. I may just sell it and be done at this point and be upfront with what I have experienced, I truly believe it’s fine, and just my set up. .

But im going to check out the blade on the Mamo right now... I may be asking how to “recenter” soon!
 

·
Registered
Joined
·
312 Posts
When you push the blade fully closed, it should come back out to its natural resting place. If it does not come back to that part open positions it is getting stuck.

Yep same deal, down shit and bad shudder until you get out of it. Any shift at WOT above 1st to 2nd and limp mode. I bought an AC Delco LS2 from Jegs for about $380, works flawless. Just hate to waste the ported one that was even more than that. Should have went with a Nick 102 boosted from the beginning, but then I am getting into porting the snout even more and even more cost. UGH it never ends. We got a 1/2 mile event in a 9 days so I hate to go jack with it unless this is something other than a snipe hunt. I may just sell it and be done at this point and be upfront with what I have experienced, I truly believe it’s fine, and just my set up. .

But im going to check out the blade on the Mamo right now... I may be asking how to “recenter” soon!
 
1 - 13 of 13 Posts
Top