Cadillac CTS-V Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter #1
So today I come out to my car after work and had been raining on it all day. I go to start it and drive off and the “P” symbol lights up. The steering then seemed like it was running out of power steering. The DIC lit up with “parking assist off”. Then I stopped and check the parking brake and that didn’t seem to work. Then drove it home on the freeway and that’s when the dash really lit up with the traction control light coming on, Brake light on, ABS light on as the chime light is beeping at me every 30 seconds and the DIC starts saying “service suspension”.
I get off the freeway and into stop and go traffic and the “P” light stays on but the rest goes back off except for the parking assist DIC.

I had replaced the left rear shock 2 months ago with no issues. I replaced the plugs and put on some older wires 2 weeks ago and no issues until now.

Checked the connections on the coil packs, spark plug wires and shocks and nothing was loose or pinched.

The battery cables were tight as well.

I have over the last month noticed that the brakes have shuttered while braking over the last month. Just thought it was rotors that need to be replaced. I’m going to pull the wheels and check the brakes tomorrow.

Anyone run into this issue? Any ideas?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3,170 Posts
Sounds like a loose ground with all that going on. Check the one under the intake and the ones on the back of the heads.
 

·
Super Moderator
Joined
·
16,993 Posts
I had a similar issue and took a tech2 and cleared the Body control module and resolved it.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Karch

·
Registered
Joined
·
34 Posts
Must be nice. Just did a CS control arm bushing replacement on the front and wound up with Service Stabilitrak, Service Suspension System, Service Traction Control, and Service Brake Assist....F me. Just got it back from alignment so I'll see what I come with...
 

·
Registered
Joined
·
3,170 Posts
Bottom Ground bolt on airaid needed three turns. All set now.


Sent from my iPhone using Tapatalk
That thing is a bitch. Airaid shouldn't of used that bolt. Hell I just cut the tab off my Airaid.
Must be nice. Just did a CS control arm bushing replacement on the front and wound up with Service Stabilitrak, Service Suspension System, Service Traction Control, and Service Brake Assist....F me. Just got it back from alignment so I'll see what I come with...
If that was before the alignment it's normal. Having the control arms way out of wack will set all kinds of shit off.
 

·
Registered
Joined
·
1,545 Posts
If that was before the alignment it's normal. Having the control arms way out of wack will set all kinds of shit off.
Funny you should say that. I had it aligned because it was eating up the outsides of the front tires (it would like "skip" or "jump" acting clunky when hard over while parking {especially backing}) while having the new tires put on and now the Service Suspension that would show up intermittently is now gone.

That's some fancy technology.
 

·
Registered
Joined
·
3,170 Posts
Funny you should say that. I had it aligned because it was eating up the outsides of the front tires (it would like "skip" or "jump" acting clunky when hard over while parking {especially backing}) while having the new tires put on and now the Service Suspension that would show up intermittently is now gone.

That's some fancy technology.
If it's thowing a service suspension if has to be extremely out of alignment. The jumping you feel while backing up and hard over is normal with this car.
 
  • Like
Reactions: Blades1_99

·
Registered
Joined
·
1,545 Posts
If it's thowing a service suspension if has to be extremely out of alignment. The jumping you feel while backing up and hard over is normal with this car.
According to the alignment guy, it was pretty toed in but drove straight. I would get the DIC when taking really tight turns on two 360 on ramps I use to get on the interstate.

Good to know about backing up. Thanks
 

·
Registered
Joined
·
3,170 Posts
According to the alignment guy, it was pretty toed in but drove straight. I would get the DIC when taking really tight turns on two 360 on ramps I use to get on the interstate.

Good to know about backing up. Thanks
It's the camber that throws if off. And it is normally a lose CA on one side that results in the ride hight sensors being out of wack.
 
  • Like
Reactions: random84

·
Registered
Joined
·
34 Posts
That thing is a bitch. Airaid shouldn't of used that bolt. Hell I just cut the tab off my Airaid.


If that was before the alignment it's normal. Having the control arms way out of wack will set all kinds of shit off.
Def before, but it stayed after. Also comes and goes.
 

·
Registered
Joined
·
224 Posts
Mine goes "service suspension system "
Out of the blue
But I got my stereo changed to the tesla style so I don't know if related or not
Should I check or just go on (I don't think I feel something wrong) I just clear it with the desh info and press the sport suspension.
Can it effect anything else? Will it show in dtc?
Thanks
I have spare 2 rear shocks I ordered just in case
Can it be a control module? If so where is it located or part no
Thanks
 
1 - 13 of 13 Posts
Top