Cadillac CTS-V Forum banner
1 - 20 of 51 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·

·
Registered
Joined
·
3,276 Posts
@adam112 is on here and you should get it.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
@adam112 is on here and you should get it.
Awesome, Thanks.

Purchased it this morning. Also good to know I am buying from people that are on here.

Seems like a better option adding the dsx external fuel pump this way compared to drilling the tank.

I will post my results on here after I get it installed.
 

·
Premium Member
Joined
·
16,486 Posts
Awesome, Thanks.

Purchased it this morning. Also good to know I am buying from people that are on here.

Seems like a better option adding the dsx external fuel pump this way compared to drilling the tank.

I will post my results on here after I get it installed.
I have one of his first stage 2 hats. He personally installed it into my Daily Driver for me after driving to OH from NC.


Currently pushing 900+ wheel on e85 with no problems, no leaks, and no extra holes in my tank.

My only complaint about Adam is that he doesn't advertise more!

ETA: 400" build, AllPro heads, Dw300 in-tank injectors with factory rails, ID1300x2 injectors, Adam's stg2 hat and a dsteck pump. Kong 2650 blower pushing 19psi (840ish RWHP on 93 pump here) in 65* F weather, only pulling 65% duty cycle.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
I just happened to stumble on his install youtube video and I am glad I did. It seems like the best way to go if you plan to run an external pump.

I am currently running two of the Deatschwerks DW300c and plan on adding in the dsx kit once I hit the limits of them.

Hopefully with the ALM hat it will also allow those pumps to flow a bit better.
 

·
Premium Member
Joined
·
13,458 Posts
is the CEL issue solved? I havent been paying too much attention to all this I just know I wasnt crazy about making a hole in my tank or running a set up that you needed to keep more than 1/3 full
 

·
Premium Member
Joined
·
16,486 Posts
Adam's fuel hat comes with a Holley fuel mat - which are amazing. I have run mine around 1/8th of a tank without issues but I also don't really see the point in pushing it on a nearly empty tank.

The short of it is the more expensive Fore / Squash systems still have that problem from what I've seen. The Holly Fuel Mat solves the problem, if there is room to fit.

ETA: I do still get a CEL due to low voltage from secondary pumps (relay used), but even turning off all the FPCM error reporting and it will still trip. Then resets, and trips as soon as the secondary pump kicks in. Oh well.
 

·
Registered
Joined
·
3,135 Posts
@random84 I’m open to a marketing workshop with you. Seeing as this is my full time gig now. You just keep telling me to start stripping. I know that would be lucrative, but the hours...ugh

Hoping to have some cool stories and nice slips from MIR in two weeks pushing a MoTec controlled 6L90 car to the brink! (Different fuel setup than this but still ALM and worth checking out!)
 

·
Premium Member
Joined
·
13,458 Posts
i can deal with an occasional CEL, but does it coming on put the car into guardian mode and just as important does it trigger a fail come emissions testing time?
 

·
Premium Member
Joined
·
16,486 Posts
i can deal with an occasional CEL, but does it coming on put the car into guardian mode and just as important does it trigger a fail come emissions testing time?
So I only get a CEL. There are no other issues - I can do sweet rolling burnouts at 80mph with no issues, 900+ wheel on ethanol on 70psi rail pressure, etc... but I have disabled a few codes (ie they are no longer reported), affiliated with the FPCM; no rear 02 sensors, even the baro sensors on the Supercharger as I have a Kong and hit 19psi in good air. Normal stuff for mods, really.

Now the caveat here is that the FPCM just has a generic "request engine light" code that becomes permanent once it sends to the ECM when it has a problem; but it's nonspecific and I'd probably have to tune the FPCM to truly get rid of it (if that's even feasible)... but even disabling that feature and clearing error, the CEL still pops up. Adam installed a relay for the Aux Pump to avoid any voltage issues, and I think that's what is driving the CEL (secondary pump voltage low is one error that gets reported); but although I disable the CEL codes, the light still turns on when I get into boost and the Aux pump kicks in.

I would expect you to pass a tailpipe emissions test as long as the permanent codes are cleared and your idle / part throttle speed density tune is dialed in - but that's up to you based on specific state rules, your cam, tuning, etc.

Clearing the codes are easily done by doing a cold start, idle for more than 30 seconds, drive normally (no boost) for 20+ minutes, then idle another 30 seconds before turning the car off (they will not clear with a simple scan tool or HP Tuners). So I clear the light typically on my way to work, then trip it again when I data log a pull on the way home. Ha.
 

·
Premium Member
Joined
·
13,458 Posts
no sniffers here, just plug in and if any CEL or "not ready" its a fail
also if you clear codes you need to have a certain amount of miles on the car before it can be inspected ( otherwise everyone would just do that lol )
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #13 · (Edited)
If I order the DSX kit to add on to the fuel hat would anything else be needed for the install (other than the 6 an elbow to come off the hat)? I looks like it has about everything I would need, I just want to make sure I'm not missing anything.

I appreciate everyone's help. This community is amazing!!!
 

·
Premium Member
Joined
·
2,963 Posts
^^ You would need to build a new fuel hose from Adam's hat to the DSX pump. Unless Adam supplies it with the kit, but I don't think so. It's not hard to do though.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #15 ·
^^ You would need to build a new fuel hose from Adam's hat to the DSX pump. Unless Adam supplies it with the kit, but I don't think so. It's not hard to do though.
Adams hat has a 6an fitting coming out of the hat. Is there not enough hose on the DSX kit to reach the top of the tank with the hose provided with the kit? planned on using the hose that provided just skipping the 90 degree fitting used when tapping the tank?

I will order up a few extra AN connectors and hose just to be safe.

Thanks
 

·
Registered
Joined
·
3,135 Posts
You don’t need more hose length. Just the additional -6 90 adapter on the top side, only thing Not included.
 

·
Premium Member
Joined
·
16,486 Posts
I can attest that the Dsx pump kit fits. All you need are the correct AN adapters.


Sent from my SM-G965U using Tapatalk
 

·
Premium Member
Joined
·
13,458 Posts
if the DSX kit fits can you still run the stock pumps as not to deal with any FPCM issues? ( for us sub 800hp guys lol )
 
1 - 20 of 51 Posts
Top