Cadillac CTS-V Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
806 Posts
Discussion Starter #1
OK I think I may have missed something maybe when doing my reinstall getting couple codes and I think it's do to a bad ground maybe I'm getting problem.with knock system and low reference on crank position. So I have 1 ground on driver head and 3 grounds on pass head in have the one under the air box and there one behind pass headlight. And one on pass. Strut tower am I missing anything?

Thanks guys
George
 

·
Registered
Joined
·
1,323 Posts
OK I think I may have missed something maybe when doing my reinstall getting couple codes and I think it's do to a bad ground maybe I'm getting problem.with knock system and low reference on crank position. So I have 1 ground on driver head and 3 grounds on pass head in have the one under the air box and there one behind pass headlight. And one on pass. Strut tower am I missing anything?

Thanks guys
George
Having just reinstalled the heads on mine, i'd say you have the right number installed on the heads. I cant remember which side the knock sensor is on, but I'm wondering if you may have pinched a wire or two putting the accessories on or maybe have a pin pushed out on those 3 big connectors on the DS? I pinched a crank wire once and the car ran and drove fine,, until the customer took it, and then it broke down in the rain 5 miles from the dealership.. It was bad. Back in my much younger days.. I'd take an inspection mirror and follow the wires just to be sure. My .02. Good luck. BTW I'm trying to figure why I have a P012B code popping randomly.. ugh
 

·
Registered
Joined
·
806 Posts
Discussion Starter #3
Pulling all the grounds and cleaning them only thing I can think of
 

·
Premium Member
Joined
·
14,392 Posts
using some electrical cleaner on the connector pins might be a good idea if you had greasy fingers pulling things apart. Cleaning the MAF sensor with an appropriate MAF-compatible cleaner is also a good idear.
 
1 - 5 of 5 Posts
Top