Cadillac CTS-V Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
New here and to the caddy. So quick question what would cause the fans to not come on. It gets up to about 220-230. The previous owner says it has an ls2 not the ls6. Also told me it's an 08 engine.
 

·
Registered
Joined
·
868 Posts
If it's a swap I wonder if he messed something up with the harness, I don't recall what ecu pin the fans are, but you could check the fans with a jump box to verify they work, check the relays etc... Also see if the fan turns on with the a/c.
 

·
Registered
Joined
·
868 Posts
If it's an 08 engine and doesn't have a crank sensor converter box, or a new ring on the crank, it would need a newer ecu as well.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
So I checked the fuses. They are good. The 2 30 amp square fuses. Not sure how to check the relays. Could it be the temp sensor? But the gauge and display work fine. The gauge sits in the middle.

If it's an 08 engine and doesn't have a crank sensor converter box, or a new ring on the crank, it would need a newer ecu as well.
Did they make a cts-v in 08. Every time I googled it the years went from 03 -07 then 09 -to present.
 

·
Registered
Joined
·
868 Posts
Easiest way for a novice to check the relays would be to pull the relays out, pop the plastic cover off, put them back in and manually move the switch to see if the fans turn on, then you can check the trigger power to them if they do turn on, or if they don't you can start by checking the constant power to the relay, direct power to fans, and so on.

I usually start at whatever component isn't working and work my way back to the power source.
 

·
Registered
Joined
·
2,120 Posts
Or you could just figure out which terminals on the relay are the contacts, pull the relay from the block, and jumper those spots on the female connector.
 

·
Premium Member
Joined
·
2,944 Posts
What year is your V? 06-07?
06-07 V1's came with LS2.
No V was made in 2008.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
What year is your V? 06-07?
06-07 V1's came with LS2.
No V was made in 2008.
It's an 04. Supposed to have 08 suspension and engine. But like you said they didn't make one in 08. So I need to get the numbers off the block to find out. But the overheating is problem number one.
 

·
Registered
Joined
·
868 Posts
You could and should pull the relay n jump the terminals, but if you don't understand how a relay works that could end badly lol.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #12 ·
You could and should pull the relay n jump the terminals, but if you don't understand how a relay works that could end badly lol.
I know how they work. Just new to the caddy and didn't know if this was a common problem or not.
 

·
Premium Member
Joined
·
2,944 Posts
He has an 04 V with an 08 LS2 engine and 08 suspension. Don’t know where he got the 08 V suspension.
 
1 - 15 of 15 Posts
Top