Cadillac CTS-V Forum banner

1 - 14 of 14 Posts

·
"V"roooooom
Joined
·
57 Posts
Discussion Starter · #1 ·
Well, I got my car on Halloween and every so often it will struggle to start. On Wednesday it threw a p0336 code (crank position sensor) while starting. I took the negative off of the battery for a few minutes to reset the code because it ran like crap. After that it ran like champ again. Then on Thursday I go to work with no problems. Leave work for my oil change, no problems. So I park it in the service bay, no problems. Service moves it outside, no problems. Then they go to move it into their bay to change the oil and it wouldn't start (no code popped up). Battery tested good too. Nobody there could figure it out so I had to get my personal stuff out of it to take a loaner home and I lock the doors and decided to remote start it and it fires right up. It's still there with no info about it on Friday.
FYI - I miss her already


Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
2,238 Posts
Every time the car was started did it seem to struggle more and more ? This is how my starter went out... I was on my like 4th stop within 30 mins and it just stopped trying to turn over.
 

·
"V"roooooom
Joined
·
57 Posts
Discussion Starter · #3 ·
The day it threw the code , it was on its 3rd start-up with in 30 minutes. The next day it too was on its 3rd start-up when it wouldn't start, but it was closer with in an hour or so between them.
 

·
Registered
Joined
·
2,238 Posts
Yea after like 2/3 start ups my car would barely turn over... next day was fine on the first start. Mine never threw a code though
 

·
"V"roooooom
Joined
·
57 Posts
Discussion Starter · #5 ·
Yea after like 2/3 start ups my car would barely turn over... next day was fine on the first start. Mine never threw a code though
I see that you are having trouble getting it removed, any luck yet?

Sent from my SM-N950U using Tapatalk
 

·
"V"roooooom
Joined
·
57 Posts
Discussion Starter · #7 ·
Update - Cadillac dealership replaced the positive and negative wires that are going to the battery. They said that there was a problem with the voltage. Its working/starting fine right now. So happy to have my baby back
 

·
Registered
Joined
·
144 Posts
This is good information to know. If you could post the repair order with the battery cable part numbers, it could be helpful to the V3 community if one of us has a similar problem out of warranty. Thanks in advance.
 

·
"V"roooooom
Joined
·
57 Posts
Discussion Starter · #9 · (Edited)
Hopefully the last update with this - it did it again with not starting up. The bad part was that I had the wife and kids with me out eating supper. Had to get it towed for the 2nd time. First time was at Cadillac Attack in Orlando. But this time was in Savannah. Anyways, they said the battery has a dead cell in it and I replaced it 2 weeks ago. So O'Reilly's was able to swap it out and then the dealership said that now it's the starter. It was replaced under warranty and there's a huge difference when it starts up now. This is definitely what the problem was all along.
150221
150222
 
  • Like
Reactions: loweredd

·
Registered
Joined
·
2,243 Posts
the long crank issue and cam code could also point to hpfp or check valve in the lp fuel line.
 

·
Registered
Joined
·
144 Posts
I am now having issues with 5 second cranks with my V with 48000 miles. Is there a check valve in the LP fuel line I can check, or is it built into the tank pump. Very annoying in an otherwise perfect running car.
 

·
Registered
Joined
·
2,243 Posts
I am now having issues with 5 second cranks with my V with 48000 miles. Is there a check valve in the LP fuel line I can check, or is it built into the tank pump. Very annoying in an otherwise perfect running car.
yes , the line in the rear from the hardline that goes over the oem supercharger has a check valve inside , dont ask how i know . its not noticable until you take the line off and feel the small clamp inside the loom.
 
1 - 14 of 14 Posts
Top