Cadillac CTS-V Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1 (Edited)
Lately when I drive the car (on several different occasions) the OEM headunit will have lines across the screen and the display image will "glitch". This happens regardless of the screen position or if the unit is "off" or if I'm playing music. I can't seem to replicate what causes it but know that the lines/glitching get worse when I rev the car or go full throttle. I've had this issue randomly in past years but it quickly went away. This time it seems to be here to stay. I found someone on Facebook with a similar issue but we are still scratching our heads as to the fix.

If I decide to replace the OEM with another factory unit - what is the best route to pick one up? Any other ideas?

Here's a video of our issue:

 

·
Registered
Joined
·
169 Posts
I'm having the same problem, I may schedule a appointment at cadillac and see what they say.
Lately when I drive the car (on several different occasions) the OEM headunit will have lines across the screen and the display image will "glitch". This happens regardless of the screen position or if the unit is "off" or if I'm playing music. I can't seem to replicate what causes it but know that the lines/glitching get worse when I rev the car or go full throttle. I've had this issue randomly in past years but it quickly went away. This time it seems to be here to stay. I found someone on Facebook with a similar issue but we are still scratching our heads as to the fix.

If I decide to replace the OEM with another factory unit - what is the best route to pick one up? Any other ideas?

Here's a video of our issue:

I'm having the same problem, I might schedule a appointment at Cadillac and see what they say.
 

·
Super Moderator
Joined
·
20,870 Posts
As for the head unit, most are swapping over to the Tesla style unit. Theres a whole thread about it.
I wouldn’t say most people are changing. Many people, sure, but most...I don’t know about that.

Then again, how many are using their Gen2 as a daily driver?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
169 Posts
I wouldn’t say most people are changing. Many people, sure, but most...I don’t know about that.

Then again, how many are using their Gen2 as a daily driver?


Sent from my iPhone using Tapatalk
As for fixing the Oem unit, I'm not sure of the cost but if it was around the same price of the Tesla style, I'd lean towards the Tesla. There's always the Alpine unit as well. Again, that's just me.

I'm one of those few using the V2 as a daily, hints minor problems starting to surface smh. I hope they stay minor.
 

·
Super Moderator
Joined
·
20,870 Posts
I was only thinking in terms of numbers. If 50-100 converted, out of 10k Gen2 V’s, it’s still a pretty small number.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
41 Posts
Discussion Starter #7
I'm having the same problem, I may schedule a appointment at cadillac and see what they say.
Thanks - please keep me posted.

Based off my preliminary search, a new oem unit is about $200. I'd like to avoid taking the dash apart if there's an easy fix.

Not a huge fan of the Tesla unit's UI. I'd prefer to go the Alpine route but couldn't stand having a cluster of buttons that no longer worked. A guy had modded his DSP to fit into this space after removing these buttons but it looked like quite the undertaking. I find it odd that the Metra kit doesn't have a provision to delete these buttons, etc, similar to how they have been relocated in the Tesla dash kit.

Then again, how many are using their Gen2 as a daily driver?
👋 😎
 

·
Registered
Joined
·
169 Posts
I agree, in terms of numbers that is correct. So a slim portion of guys are switching over. If the oem is $200......im sticking with oem!!!!!
 

·
Registered
Joined
·
169 Posts
Thanks - please keep me posted.

Based off my preliminary search, a new oem unit is about $200. I'd like to avoid taking the dash apart if there's an easy fix.

Not a huge fan of the Tesla unit's UI. I'd prefer to go the Alpine route but couldn't stand having a cluster of buttons that no longer worked. A guy had modded his DSP to fit into this space after removing these buttons but it looked like quite the undertaking. I find it odd that the Metra kit doesn't have a provision to delete these buttons, etc, similar to how they have been relocated in the Tesla dash kit.



👋 😎
I'll keep you up dated for sure. I will call the dealer today to schedule. I'm sure they will put me two weeks out.
 

·
Registered
Joined
·
169 Posts
I have my appointment this Friday and it hasn't had any problems since Monday. What I have noticed is when I use the AUX ( Tuna Fly plugged in the USB) it started to glitch. I haven't used the AUX since Saturday. I will use it tmro and see what happens.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #12
I have my appointment this Friday and it hasn't had any problems since Monday. What I have noticed is when I use the AUX ( Tuna Fly plugged in the USB) it started to glitch. I haven't used the AUX since Saturday. I will use it tmro and see what happens.
Any update here? Mine will do it even if I'm just listening to the radio or intermittently when I reverse in the car.
 

·
Registered
Joined
·
169 Posts
I took it to the dealer last Friday and of course it was not flickering, I showed the tech a video I took of it and he said he would have to see the screen doing it in person. They wanted to charge a $180 Diagnostic fee but since the screen was not flickering I hold him no.

I told him WHEN the screen does it again I'm going to bring it in without a appointment. They put me a week and a half out and within that time it fixed itself. I'm sure it will act up again soon.

I did ask him if he knew what could be causing the flickering and of course them being a dealer, he said he would have to do a diagnostic test to find out. I then asked him, people having my same problem, what is the usual fix. He said "its hard to say, I would need to do a diagnostic check"

No help what so ever. They really wanted that $180 from me. With my warranty, they will cover the diag. Fee but if the dealer reports no finding, then I have to pay the $180.

The weird thing is them knowing I have a warranty, you would think they was just fix it and charge it to the warranty........idk.
 

·
Registered
Joined
·
1,771 Posts
The dealership isn't capable of diagnosing the fault, only verifying it. Then they'll give you a price to replace the display, which is what's busted. The behavior you see is a sign of either an intermittent connection between the display and the driver circuit that runs it, or an impending total failure of some component of that driver circuit. I'm pretty sure the driver is in the display itself and not the HU box, though I could be wrong.

If you can't make it happen with mechanical shock (banging on the dashboard for example) it's not an intermittent connection, it's electrical. In which case it may be triggered by electrical noise. Try loading down the power system as much as possible, turn on the AC fan on high/recirc, turn on the seat heaters and fans, headlights, fog lights, rear window defroster, run the wipers, move the seats, see if it happens more often...

I have a Tesla unit in my car. It's not perfect, but then neither is the antiquated factory HU. The Tesla is better than the factory HU in spite of its faults. I'm really happy with mine. Especially because it actually looks like it's OEM. It bothered the hell out of me that I was driving a car made in 2014 that used a stereo designed prior to 2008. Now I can run any Android app, music streaming services, the program that lets me check the IP cameras around my house, the stupid Ring doorbell app ("I can't come to the door right, I'm driving my car"), my Slingbox (if I want to watch TV while driving, which of course I do whenever there's a NASCAR race being broadcast. Nothing better than watching a car race while driving your car), WebEx/Zoom (with a camera. Nothing more entertaining than doing a video conference while you're driving) and of course Torque which looks awesome running on a display built in to the center stack as opposed to a tablet velcroed to the dashboard.
 

·
Registered
Joined
·
169 Posts
That's awesome! Seems like the Tesla unit has a lot of perks to it. I like it even more now.

What I did notice is when I stab the throttle, there is a little flicker then it goes away. The flicker doesn't stay, only on the initial stab of the throttle.
 
1 - 15 of 15 Posts
Top