Cadillac CTS-V Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
Ok so I have an issue. My driver side high beam and drl have not been working since I purchased the car. I recently put in a new drl and headlight. Now the drl is working but still no high beam on the driver side only. Is there a fuse or something I can check that might be causing that issue?
 

·
Registered
Joined
·
44 Posts
The right headlight and left are fused independently. Check the fuses first. If that is not the problem check to see if you have power to the bulb. Will go deeper if that is not the issue. The BCM controls the ground via the switch.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
The right headlight and left are fused independently. Check the fuses first. If that is not the problem check to see if you have power to the bulb. Will go deeper if that is not the issue. The BCM controls the ground via the switch.
If its the fuse would the low beams come on?
 

·
Registered
Joined
·
872 Posts
There's a shutter that opens for the high beam. There's only one bulb for both low and high. My drivers side high beam doesn't work because one of the wires to the shutter is broken. I wil have it fixed when I blackout the headlights because it's a pain to open the headlights just to fix the wire. With the headlight out of the car I can see the wire by moving stuff around via the bulb access.
 

·
Registered
Joined
·
44 Posts
the headlights are fuse independently. Two for low and two for high. Open the fusebox under the hood and they are marked.
 

·
Registered
Joined
·
44 Posts
Has the harness been inspected if the car had not been wrecked and repaired then b look at the headlight switch or body control module.
 

·
Registered
Joined
·
44 Posts
if you have a test light you could check for power at the bulbs. I have seen both bulbs blown and could not think it would have happened. Second, if you check for power at the fuse see if it is there.
 
1 - 8 of 8 Posts
Top