Cadillac CTS-V Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hey,
ive read through a bunch of discussions about transmission shudder, torque converter issues, MAF issues, and fueling issues and I need some help.

Background: I purchased a new to me 2017 V3 that was a prior lease and then lightly modded by the selling dealer. I can see through its service history that in 2020 the dealer performed a transmission service which I’m assuming was the flush. In terms of mods, the car has 54k miles and has been tuned both ecu and trans but I’m not sure who the tuner was. I believe it was tuned through HP Tuning suite. As far as mods, the car is running Speed Engineering headers, and catless X pipe into the factory mufflers. It has a griptec 2.30 upper pulley and an ATI 9.17 lower with green belt.
The Problem: I’ve noticed the car runs great unless you are in 4th gear+ and try to be aggressive on the throttle. If you do that, the car struggles to down shift, loses boost, and sputters and almost acts like it’s the computer limiting power. I can drive around in 1st through 3rd gear without issue but it seems like anything above 3rd and it doesn’t like it. At first I was thinking maybe belt slip because I’m losing boost but I’m thinking belt slip would occur in all gears? Im thinking it has to be transmission related because it’s not as noticeable in manual mode except if I do a big pull and then let the RPMs come back down and try to get an aggressive roll on in that same gear it will show it’s ass again and shudder and drop boost.
I have read some posts saying to try and peddle the car to see if it fixes itself but the problem seems to stay. The only fix seems to be to down shift to get the RPMs up and then get aggressive which seems to fix it. I can do a 2nd gear WOT run through 5th gear without any issues at all but if I attempt to do the same run in 4th gear the car doesn’t like it.

what do you think? Am I missing something? Appreciate any and all help. I don’t own an HP Tuning setup but I will pick one up for the sake of data logging
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #2 ·
Quick re-attack on this. It also has a 160 thermostat. I don’t believe it has any fueling other than stock
 

·
Registered
Joined
·
1,199 Posts
I think you should have someone reputable look over that tune. Start there. Any dtcs? Not just any Tooner can tune these new vehicles.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
I think you should have someone reputable look over that tune. Start there. Any dtcs? Not just any Tooner can tune these new vehicles.


Sent from my iPhone using Tapatalk
No dtcs as I think the tune probably has some of that shut off. As far as the tune, I have an appt with Pat G down here to take a look at it the first week of July.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
Okay so quick update on this. Since my last post and while I’m waiting to get into the tune shop, I decided to replace the plugs and wires and found 3 wires completely burned/torn right where the boot meets the wire. A quick drive after replacing seems to have resolved my issue though I still notice what seems like the torque converter holding the gear for a little longer than it should when it should be downshifting. I am thinking this could be a trans tune issue so I’m hoping Pat G can fix that.
 
1 - 7 of 7 Posts
Top