Cadillac CTS-V Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
hello!! I have a question for you!
My name is Kim minkyu and I am riding the 2010 CTS-V in Korea.

I'm sending you a message because I think I had the same symptoms as my car while googling.

When my car stops, it turns off.

I checked the fault code after receiving it from the service center, and ECUP0601 came up.

In the case of other CTS-Vs in Korea, it could be because of the grounding of the bottom part equipped with airaid company's open air intake.

The same P0601 code occurred even though I modified the part, and the car was turned off.
Do you happen to change to a new one and then ecu and addressed not be the same symptoms?!
 

·
Registered
Joined
·
3,238 Posts
hello!! I have a question for you!
My name is Kim minkyu and I am riding the 2010 CTS-V in Korea.

I'm sending you a message because I think I had the same symptoms as my car while googling.

When my car stops, it turns off.

I checked the fault code after receiving it from the service center, and ECUP0601 came up.

In the case of other CTS-Vs in Korea, it could be because of the grounding of the bottom part equipped with airaid company's open air intake.

The same P0601 code occurred even though I modified the part, and the car was turned off.
Do you happen to change to a new one and then ecu and addressed not be the same symptoms?!
What were your car's symptoms? Are you saying that double checked the ground, cleared the code, and it came back?

Pictures of the car?
 
  • Like
Reactions: jcs003

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
We have a K&N intake system dedicated to CTS-V today, but the ECU GMP0601-00 code is displayed.

Finally, we decided to replace the ECU.

Have you experienced any of these symptoms?
 

·
Registered
Joined
·
3,238 Posts
The ground can be weird.

Before replacing the ECU I would have cleared the codes.
 

·
Registered
Joined
·
927 Posts
See if it runs with the maf un plugged, your car might not like the extra air from the intake. I had this issue once when the filter came off the pipe inside the box on the airaid.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Thank you for your reply~!! With the new k&n air filter installed, the symptoms of turning off the engine disappeared, but the ecu's fault code, p0601, was still left!
 

·
Registered
Joined
·
2 Posts
The ground can be weird.

Before replacing the ECU I would have cleared the codes.
This! Haven't done much wrenching on my V as it's still my daily and still under CPO warranty for a few more months. That being said, I can say with 100% certainty that a bad ground can cause all sorts of weird random issues, from a simple check engine light to major drivability issues. To the original poster, if you have any doubt that the ground wire is installed correctly check it again and make sure that it is! Replacing the ECU should be a last resort. Go over all your connections again first. If there was no check engine light prior to the intake install I would bet it is either a loose plug somewhere over there or the ground is not making good connection to ground.
 
1 - 7 of 7 Posts
Top