Cadillac CTS-V Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter · #1 ·
Im constantly having issues with my key fob not being detected in my '09. Its stupid we have a key that has issues but then still have to turn a fake key to start the car. Has anyone converted their ctsv to a column lock or different system.

I've put new batteries in both fobs, try both in the console slot and it just seems like it works when it wants. I have a fairly new car battery that sits on a tender and when I checked it, it was over 12.35v. I also had a jumper on it while trying to start and wouldn't detect the key.

I broke my fake key trying to turn it when I stuck in accessory mode after parking to grab some lunch a couple of months back. Ordered a new one but this feature is pretty lame when its not functional all the time.
 

·
Registered
Joined
·
2,108 Posts
The ECU is configured to look for the RFID of the key being detected by the RFA module. Even if you disabled the column lock so you could turn the "fake key", the car would not run. It might not even crank. You should locate the RFA module and remove it and inspect/clean all its connectors. I suspect it has an external antenna connection too, and that would be a good place to focus most of your effort. From your description it sounds like a signal strength problem and whatever the RFA uses for an antenna would be the most likely culprit.
 

·
Registered
Joined
·
71 Posts
Your key battery is going out. Get one with a lifetime warranty, as I replace mine every year.
 

·
Premium Member
Joined
·
1,283 Posts
Just an FYI. I found that if my phone is in the same pocket as the fob, I will get the "Key not detected message".
 
1 - 6 of 6 Posts
Top