Cadillac CTS-V Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
hey guys If installed the new cam, lifters, Chain and sprocket. I followed the directions I was given step by step.I put the heads back on and installed the pushrods and rocker arms with both trunion upgrade and springs as well. I was working on doing the rocker arms but came across resistance while trying to turn the crank. It would spin a little then go back to the original spot. There’s also like a breathing sound. I do have the front cover off still. Did I miss anything? I don’t think I did as I followed the directions step by step.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #5 ·
Sounds like compression. Take off the spark plugs and it should spin easier.
I back tracked on thought there’s no way I did something wrong. My only thought was maybe too much pressure. I’ll take the spark plugs out and see if that helps. Should I put them back in after I do the rockers? Or just release some pressure and put them back in?
 

·
Premium Member
Joined
·
4,245 Posts
I had the same resistance that would progressively get worse when rotating the assembly, but all of the plugs were out! I almost had a stroke when I saw that the microfiber rag that I used to cover the gap below the oil pump was no longer there.....o_O Luckily, reversing the rotation allowed me to slowly pull out the mangled rag in one piece and I was able to origami it back into a complete square, showing that nothing except a few fibres were missing.
 
1 - 8 of 8 Posts
Top