Cadillac CTS-V Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, I'm very new to the forum. I have a 2011 CTS-V and I'm having issue with the radio. Every time I turn on the car the "Cadillac start up screen" with the Cadillac emblem stays on the screen. The music plays and I can change the radio station and even the media of what I'm listening to but can never see what I'm listening to. Every 45 seconds to a minute, the radio will briefly restart and the music will cut off for a second. It is very frustrating and I'm hoping that someone on here can help me with this issue before I take my car to the dealer and get charged an arm and a leg to fix this issue. Thanks in advance. Anything helps!
 

·
Registered
Joined
·
2,308 Posts
You need a hard reset and turning the head unit off from the dashboard doesn't actually turn it off. Find the fuse for the entertainment system (under the hood) and pull it. Wait a minute and reinstall and then see if the problem goes away.

My head unit has gotten "stuck" twice in 4 years. The display stays up and all I see is the Cadillac emblem. Pulling and reinstalling the fuse has fixed it each time...
 

·
Registered
Joined
·
4 Posts
You need a hard reset and turning the head unit off from the dashboard doesn't actually turn it off. Find the fuse for the entertainment system (under the hood) and pull it. Wait a minute and reinstall and then see if the problem goes away.

My head unit has gotten "stuck" twice in 4 years. The display stays up and all I see is the Cadillac emblem. Pulling and reinstalling the fuse has fixed it each time...
I'm having the same problem but I am unable to determine which fuse controls the entertainment system. Can you help? I have the Owner's manual and the fuse layout.
Thanks
 

·
Registered
Joined
·
2,308 Posts
Sorry, JS, I don't remember. No longer use the stock HU, replaced with Android "Tesla Style" tablet thingy.

Someone else might know off the top of their head, though... if you're lucky they will respond with the info.
 

·
Registered
Joined
·
4 Posts
Thanks for the quick response. I was able to find the appropriate fuse in the Trunk. It turns the display and screen off. I pulled it and waited a couple minuted and replaced it. Sadly the reboot issue persists. When I turn it on, The Cadillac emblem comes on with the radio and after a short period the screen goes black. after another 30 to 45 seconds the system reboots, the Cadillac emblem appears and the radio returns. I plan to replace the fuse with a new one to see if that helps. I assume that the display is OK since it comes on and displays the Cadillac emblem. Do you agree?

I also saw an article that recommended bypassing the trunk battery and connecting the positive and negative cables to reset the radio. I also tried this but it didn't help.
Any thoughts or recommendations?
 

·
Registered
Joined
·
2,308 Posts
In my case, the logo appeared and stayed there forever, no self-reboots. I'd hazard a guess that the hard drive is bad based on the symptoms you describe. It tries to spin the HDD up, fails after a timeout expires (and HDD time-to-ready timeouts are often set to be around 30 seconds), gives up, reboots, tries again.
 

·
Registered
Joined
·
4 Posts
Interesting, excellent information. I assume that the hard drive is part if the radio, not part of the screen. One of the built in features is the backup camera. It works great.
 

·
Registered
Joined
·
2,308 Posts
Yeah. There's a HDD inside the HU with all the mapping data and any music you've saved there and probably, the operating system that the HU uses in order to do what it does. The backup camera doesn't actually use the HU for control. When you go in to reverse, the camera turns on and a signal going to the HU makes it bypass all the internal HU stuff and display the camera image on the display. So it's not surprising that it works while nothing else does, I'm afraid. :(
 

·
Registered
Joined
·
4 Posts
First of all I want to thank you for all the information. You've obviously had a lot of experience with this sort of thing. I have a couple more questions that I hope you can help me with.

If I need to replace the the HU, do you have a recommendation on where to find a reputable replacement? I don't think I'm able to justify a new one. The prices I've seen are about $2000, used units on eBay or Amazon scare me.

While I have been diagnosing the Video issue I noticed that the driver's window is no longer closing when I get in the car. If my memory suites me,,, this happened about 3 year's ago and I found that the trunk battery was weak and needed replacing. I plan to have the battery tested today to see if that is the problem. Have you seen this isn the past?

Thanks again for all you help
 

·
Registered
Joined
·
3,656 Posts
First of all I want to thank you for all the information. You've obviously had a lot of experience with this sort of thing. I have a couple more questions that I hope you can help me with.

If I need to replace the the HU, do you have a recommendation on where to find a reputable replacement? I don't think I'm able to justify a new one. The prices I've seen are about $2000, used units on eBay or Amazon scare me.

While I have been diagnosing the Video issue I noticed that the driver's window is no longer closing when I get in the car. If my memory suites me,,, this happened about 3 year's ago and I found that the trunk battery was weak and needed replacing. I plan to have the battery tested today to see if that is the problem. Have you seen this isn the past?

Thanks again for all you help
Sometimes the window can be from door switch....it thinks the door is being opened.
 

·
Registered
Joined
·
2,308 Posts
If the power is interrupted when the window isn't all the way up, the window controller has to be retaught the up and down positions. You just hold the switch in the down position for 5 seconds after the window travel bottoms out, then hold it in the up position for 5 seconds after the window travel tops out.

Honestly, I wouldn't waste my money on a GM original HU, though I'm sure you could find something suitable on eBay. My car has a "Tesla Style" 10.4" Android tablet aftermarket head unit that basically replaces the entire center stack face plate with the display, but there is also a company called Metra that makes a replacement bezel that allows you to install a 2-Din radio, and it comes with interface electronics so it hooks right up to the car's audio system. There are threads in the forum for both "Tesla Style" and "Metra".

In the CTS-Vs with Bose, the amp is actually in the back of the car. The HU is just the "front end". So you need interface electronics if you don't plan to replace the amp, or you have to hack up the wiring harness to hook the speakers directly to a new amp.
 
1 - 12 of 12 Posts
Top