Cadillac CTS-V Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
Or is it powered by just the fuse
I’m throwing p0690
Was trying to switch out the relay and just couldn’t
Find it any ideas?
Thanks
Adam
 

·
Registered
Joined
·
3,174 Posts
PWR/TRN Relay is connect to the EMIS 1 fuse, EMIS 2 fuse, ECM fuse, Even Coils fuse, and Odd Coils fuse.
 

·
Registered
Joined
·
20 Posts
Bringing up the topic again. Are you guys talking about the relay for the upstream 02s? Or know what fuse it is for the 02 sensors. Trying to find something about it and can’t find anything. Looking into checking if mine is faulty. 3rd time my 02 sensors went out and caused my CEL to go on. ps runs fine I feel no difference
 

·
Registered
Joined
·
1,346 Posts
Bringing up the topic again. Are you guys talking about the relay for the upstream 02s? Or know what fuse it is for the 02 sensors. Trying to find something about it and can’t find anything. Looking into checking if mine is faulty. 3rd time my 02 sensors went out and caused my CEL to go on. ps runs fine I feel no difference
There isn't an O2 fuse,as the CEL is set from the ECM. What are the codes for the CEL.? Sounds like it may be a tuning thing. Without knowing mods i.e. headers, cam etc.. hard to say what is turning on the CEL, but IMO your O2 is not bad, because when they go back, your car runs like shit.
 

·
Registered
Joined
·
20 Posts
P015b and p015d. My tuner said it has nothing to do on his end. I think it’s something with electrical as my CEL went away. 2nd time where it turned on/off. I replaced my 02s twice prior to this but since my CEL is going on and off makes me believe it’s something else
 
1 - 6 of 6 Posts
Top