Cadillac CTS-V Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello experts. I'm new to the forum and recently purchased my first CTSV and have a issue I can't resolve with the speedometer not working. It was working fine after I purchased it and drove about 120 miles to family members house then 3 days later when I began my return home I noticed immediately it had quit. Now let me add I got this car from Fla and it rained non stop my entire time there. Hurricane hit the day I came back to Atlanta. I researched and replaced the vss today with no luck. The car is modified heavily and very clean for an 05 with 103k miles. Also when I do get this resolved will the computer correct the milage or will it begin from where it currently sitting. Worried the car has alot more miles than what I'm seeing. Title says 100k and PO says he only put 3k on it in 2.5 years which is hard to believe but not impossible.
Vss replaced today.
No wires were incorrectly switched since it worked fine then stopped without being touched.
If I had got water into a connection is it at the speed sensor only or is there somewhere else I should check?
Stability & check engine lights have came and stayed since this began.
Car was tuned today and he cleared the code but immediately came back.
The big connector in front of the shifter has been tampered with heavily I noticed today and wondering if the vss even goes through that plug. Thanks and apologies for the needless info. Thought It may help in some way.
 

·
Registered
Joined
·
964 Posts
VSS is also found on the plug that goes into the radio/nav.
 

·
Registered
Joined
·
1,235 Posts
What is a speedometer? I heard of a boost gauge but a speedometer must be something new.
 
1 - 4 of 4 Posts
Top