Trouble with accessory squeal! Help!
Welcome to the Cadillac CTS-V Forum at CTSVOwners.com.
Results 1 to 2 of 2
  1. #1
    Active Member
    Join Date
    Oct 2016
    Posts
    65
    Likes (Given)
    0
    Likes (Received)
    0
    I call BS (Given)
    0
    I call BS (Received)
    0

    Trouble with accessory squeal! Help!

    Had what I thought was bearing squeal, swore it was the power steering pump. Replaced the power steering pump and the squeal was still there. Apparently a slipping serpentine belt can sound like a metal on metal squeal.

    Replaced the accessory belt and the squeal went away. A day of driving and the squealing came back. Thought maybe faulty belt (first belt was napa) so I put a gates belt on. Squealing went away again.

    A day of driving and the squeal is back!

    Has anyone experienced this? The only two things I can think of is a tensioner that isn't putting enough tension on the belt causing the belt to slip, or a worn pulley that is causing slipping (car has only 30,000 miles).

    Any ideas?

  2. #2
    Active Member
    Join Date
    Jul 2014
    Location
    Dallas
    Posts
    5,798
    Likes (Given)
    205
    Likes (Received)
    209
    I call BS (Given)
    9
    I call BS (Received)
    13
    First remove super charger belt and start car. If squeal is still there, you can rule out your blower and blower idler pullies.

    At this point, spray wd40 individually on each accessory pulley until the squeak goes away. Make sure to clean he excess once you're done.
    M6: 10.88 @ 132mph

    "I've ridden in a lot of what I thought were fast cars, but yours was the first one to ever give me butterflies."

    Hidden Content


Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)