Service traction control, stumbling barely stay running limped home.
Welcome to the Cadillac CTS-V Forum at CTSVOwners.com.
Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Apr 2016
    Location
    Greenville, SC
    Posts
    18
    Likes (Given)
    0
    Likes (Received)
    0
    I call BS (Given)
    0
    I call BS (Received)
    0

    Service traction control, stumbling barely stay running limped home.

    So I have a 09 Stock M6 Sedan. I had just left the house heading down the road 25-35 mph and it started flashing the traction control, check engine light, and service stabiltrack. Started stumbling in all gears, barely made it home. Now it sounds like there is a rattle from the supercharger. Please help. I started researching and have seen possible Throttle body, supercharger rebuild/isolator. The supercharger was supposedly replaced under warranty before I got it.

  2. #2
    2X 9 second club
    Join Date
    Jul 2011
    Location
    In the Basket of Deplorable
    Posts
    8,807
    Likes (Given)
    38
    Likes (Received)
    228
    I call BS (Given)
    14
    I call BS (Received)
    12
    did you hit the rev limiter at any point?

    my 1st v2 did that once, and in the end it was a cracked sleeve.....not saying that one caused the other, but I was driving it hard, and it hit the limiter, went into limp mode and never ran quite right and later the piston broke at the ring land on #8 and cracked #6

    to get it out of limp mode, I reflashed the car and it started and ran, but never was the same up to the point where the piston broke.
    Silver surfer, 2016 Radiant Silver V3, stock
    little red- 9.99@138 on the corn best mph 139 1/4 108.6 1/8 (sold)
    big silver - 9.63@142 on the spray (sold)


    my GM High Tech article:
    Hidden Content

    See the videos at:
    Hidden Content

  3. #3
    Registered User
    Join Date
    Apr 2016
    Location
    Greenville, SC
    Posts
    18
    Likes (Given)
    0
    Likes (Received)
    0
    I call BS (Given)
    0
    I call BS (Received)
    0
    I might have about a week ago. I was driving it pretty aggressively, and had to slow quickly so I was braking, down shifting and shift into 2nd earlier than I should have. I was immediately hoping I didn't hurt anything, but it was fine for the last week or so.

  4. Remove Advertisements
    CTSVOwners.com
    Advertisements

  5. #4
    Active Member
    Join Date
    Jul 2016
    Location
    Pensacola, FL
    Posts
    73
    Likes (Given)
    0
    Likes (Received)
    0
    I call BS (Given)
    0
    I call BS (Received)
    0
    Sounds like you burnt threw a spark plug wire to me.
    TheV, 2" SW, 2.5 upper, ported t/b, 900cc injectors, 4.5 new era, full 2.5" exhaust, vadder dual HX, eibach lowered, concept one cs6 wheels: coming soon ATI (9.1)LOWER AND LJMS cam.

  6. #5
    Registered User
    Join Date
    Apr 2016
    Location
    Greenville, SC
    Posts
    18
    Likes (Given)
    0
    Likes (Received)
    0
    I call BS (Given)
    0
    I call BS (Received)
    0
    Disconnected the battery, let it sit for a bit then tried again. Sounded a little better at idle, but after a minute the service traction control popped back up. Also the exhaust tone sounds a little deeper then normal.

  7. #6
    Registered User
    Join Date
    Apr 2016
    Location
    Greenville, SC
    Posts
    18
    Likes (Given)
    0
    Likes (Received)
    0
    I call BS (Given)
    0
    I call BS (Received)
    0
    Ok, so negative update...tried drive to the auto parts store less than a mile down the road. car sounds like its trying to eat it self. Codes thrown C05561, P0300, P1101, P0430. Bought some MAF sensor cleaner, headed home and started smoking then died. Pulled the intake tube covered in oil. Sprayed it out, sprayed MAF, and throttle body. Got it started for a minute then it died again and now nothing when turn the key.

  8. #7
    Registered User
    Join Date
    Jan 2017
    Posts
    2
    Likes (Given)
    0
    Likes (Received)
    0
    I call BS (Given)
    0
    I call BS (Received)
    0
    I had this happen on ctsv 2009 with 49K km. Its due to misfire. Craked piston

  9. #8
    Active Member
    Join Date
    Nov 2014
    Posts
    161
    Likes (Given)
    0
    Likes (Received)
    1
    I call BS (Given)
    0
    I call BS (Received)
    0
    ABS sensor failure or ABS module failure. I have had it on my Yukon; and Jetta; it can throw the car into limp mode.

  10. #9
    2X 9 second club
    Join Date
    Jul 2011
    Location
    In the Basket of Deplorable
    Posts
    8,807
    Likes (Given)
    38
    Likes (Received)
    228
    I call BS (Given)
    14
    I call BS (Received)
    12
    I would run a scope into the 7 and 8 bores.
    Silver surfer, 2016 Radiant Silver V3, stock
    little red- 9.99@138 on the corn best mph 139 1/4 108.6 1/8 (sold)
    big silver - 9.63@142 on the spray (sold)


    my GM High Tech article:
    Hidden Content

    See the videos at:
    Hidden Content

  11. #10
    Active Member
    Join Date
    Jan 2015
    Location
    Toronto, ON
    Posts
    2,210
    Likes (Given)
    138
    Likes (Received)
    61
    I call BS (Given)
    7
    I call BS (Received)
    2
    Sucking oil into the intake means oil is getting past the piston. Sorry to say, but Evil V gave you the most possible cause back in post #2. Keep everyone updated with what you find out from the scope. Post pics of the plugs as you pull them, I bet you'll find one with a bent ground electrode.
    2009 CTS V Black Raven Sedan, M6, Recaro's, Ultraview
    Stage 0.6 Airaid CAI, Kooks 1 7/8" LT's, Kooks catted xpipe, stock mufflers, Mamofied LS7, NGK TR6, SM Dual CC, 160F stat, Dynojet tuned by Dave @dasilvamotorsport, SAE 526hp/508tq/91oct

  12. #11
    Registered User
    Join Date
    Apr 2016
    Location
    Greenville, SC
    Posts
    18
    Likes (Given)
    0
    Likes (Received)
    0
    I call BS (Given)
    0
    I call BS (Received)
    0
    #2 and 4 compression down to 60lbs. gonna be pulling apart soon. Supercharger will be going to Brett and other mods will depend on damage. Hoping the damage is minimal.
    I will update as I figure out what is up.


Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)